Feb 16, 2017

Rclone Is Now Available As A Snap Package [Quick Update]

cloud storage

[Quick Update] Rclone is now available as a snap package, making it easy to install and update on a wide range of Linux distributions which support Snaps, like Ubuntu, Debian, Fedora, Gentoo, Arch Linux, openSUSe and more.

Rclone is a command line tool for synchronizing files and folders to multiple cloud storages (either from your machine or from one cloud storage to another). It supports Dropbox, Google Drive, Amazon S3, Amazon Drive, Microsoft One Drive, Yandex Disk, and more.

For more information about Rclone, as well as a GUI for it, see the following articles:

To install the Rclone (currently the snap provides a development version, 1.3.5-dev) snap package, use the following command:
sudo snap install rclone --classic

This should install the Rclone binary under /snap/bin/. The "--classic" argument is used because it puts the snap in classic mode and disables the security confinement. This is required for Rclone to work, or else it won't be able to access some user files.

Later on, if you want to update the Rclone snap, use:
sudo snap refresh rclone

You can update all the installed snaps using:
sudo snap refresh

For the "snap" command to work, you need the "snapd" package. This should be installed by default in recent Ubuntu versions, like 16.04 and 16.10 or 17.04. For Ubuntu 14.04, you can install it from the repositories:
sudo apt install snapd

For other Linux distributions, installing snapd is detailed on the Rclone installation page @ GitHub.

I should also mention that there's currently only one Rclone version - 1.35-dev -, available as a snap, no matter what channel you choose (stable / candidate / beta / etc/):
$ snap info rclone
name: rclone
summary: "\"rsync for cloud storage\" "
publisher: fireeye
description: |
"rsync for cloud storage" - Google Drive, Amazon Drive, S3, Dropbox, Backblaze
B2, One Drive, Swift, Hubic, Cloudfiles, Google Cloud Storage, Yandex Files
commands:
- rclone
tracking: stable
installed: 1.35 (55) 5MB -
refreshed: 2017-02-15 22:00:31 +0200 EET
channels:
stable: 1.35 (55) 5MB -
candidate: 1.35 (55) 5MB -
beta: 1.35 (55) 5MB -
edge: 1.35 (55) 5MB -


via Web Upd8 - Ubuntu / Linux blog http://ift.tt/2lOBMfk